FAQ  •  Register  •  Login

how to change confi.ini for realistic water??

<<

JABO2009

Posts: 5

Joined: Thu Mar 18, 2010 3:33 pm

Location: Austria

Post Mon Mar 22, 2010 5:12 am

how to change confi.ini for realistic water??

hi all,

wanted to change the settings for realistic water....

1) changed the values in config.ini as following:

hardware shaders =1
water=2

is that correct?

2) wanted to save settings, but the error message is, that I have no permission to save changes...

has anyone an idea how to solve this?

IL-46 4.091bm mods on
<<

aaareg13

Posts: 43

Joined: Mon Jul 13, 2009 12:34 am

Post Mon Mar 22, 2010 6:48 am

Is your Il2 directory in the Program Files? If it is, you are not able to change .config files directly. Try dragging it to desktop, editing it, saving it, and putting your modified .config back into your game folder.
<<

JABO2009

Posts: 5

Joined: Thu Mar 18, 2010 3:33 pm

Location: Austria

Post Mon Mar 22, 2010 8:53 am

yes it is...

ok thx, I'll try to modify it this way.
<<

KG64_Cnopicilin

User avatar

Mod Member

Posts: 5044

Joined: Sun Jan 04, 2009 11:57 am

Location: Finland

Post Mon Mar 22, 2010 9:49 am

Do you have ATI or nVidia graphics card? ATI uses 2 for perfect, nVidia 4.
<<

philip.ed

User avatar

Posts: 2787

Joined: Fri Apr 25, 2008 2:48 pm

Location: Shhh! Sleeping ;)

Post Mon Mar 22, 2010 12:42 pm

To add to what cnopi said, someone once told me that later model ATI cards can work with water=4, but TBH I've seen no difference between ATI water=2 and nvidia water=4 ;)
<<

lofty_c

Posts: 15

Joined: Thu Feb 12, 2009 5:13 pm

Post Mon Mar 22, 2010 5:31 pm

aaareg13 wrote:Is your Il2 directory in the Program Files? If it is, you are not able to change .config files directly. Try dragging it to desktop, editing it, saving it, and putting your modified .config back into your game folder.



or you can right-click on the file, then properties, and change the access for your user for that file.
<<

JABO2009

Posts: 5

Joined: Thu Mar 18, 2010 3:33 pm

Location: Austria

Post Wed Mar 24, 2010 2:57 pm

I have ATI greaphic card so I changed water to =2 in config.ini but ingame, nothing happens to the water...
why????

do I have to change something on the shaders as well?

how are the correct config.ini settings for realistic water?

Il-46 4.09m1b mods on
<<

checkmysix

Skin Mod Member

Posts: 257

Joined: Sat Nov 08, 2008 8:12 am

Location: Kent, U.K

Post Tue Jul 13, 2010 8:18 pm

Re: how to change confi.ini for realistic water??

In config.ini Change ALL HardwareShaders FROM HardwareShaders=0 TO HardwareShaders=1
and Water=2,3,4 etc
Regaeds
CM6
<<

Fireskull

User avatar

Posts: 4183

Joined: Tue Jun 09, 2009 12:11 pm

Location: Milky Way Galaxy, Sun System, Earth, USA...Somewhere roaming in the mid-west of America! LOL!

Post Wed Jul 14, 2010 1:07 am

Re: how to change confi.ini for realistic water??

Hi, JABO

The true Perfect Water requires that you run your graphics settings in Anisotropic mode.

Prepare by going to your conf.ini file in the main registry of IL-2 for seeing the READ-ONLY. Right click on the conf.ini file and a window will appear. Click on the Properties tab. Another window will appear. See and make sure that there is no check in the box for READ-ONLY. THIS IS VERY IMPORTANT because before ANY graphics settings are made in the Setup, Graphics Control Panel, or conf.ini, the conf.ini must not be in READ-ONLY mode.

After all graphics settings are made, you will make the conf.ini file READ-ONLY just before restarting IL-2.


The following information about PERFECT WATER comes from my tech topic about the connection of the computer to IL-2 Benchmarking, Optimization, and Tweaking found with these links:

viewtopic.php?f=30&t=22314
viewtopic.php?f=30&t=22314&p=271026#p271026



1) Perfect Water is only available in OpenGL mode of the Setup of IL-2 (il2set.exe).

Make sure that you run Anisotropic in your Setup of IL-2. This is found in your main registry of files and folders of IL-2. Look for il2set.exe and click on the file icon. A window of the Setup of IL-2 will appear.

Make sure that the Setup window indicates OpenGL mode.

Use Custom Settings.

In the Setup box, set Texture Mipmap Filture: Anisotropic. If you think that you have a very powerful graphics card in your computer, then set Texture Compression: NONE. Do not use Palette or Texture Compression ARB Extension. Put a check in everything else especially Texture Anisotropic Extension, but not Disable All.

REMEMBER to press OK.



2) Next go to your graphics card Control Panel. Make sure that Force Mipmaps: NONE and Texture Filtering Trilinear Optimization OFF. High Quality ON.

REMEMBER to press APPLY.



3) Go to your conf.ini file of IL-2 found in the main registry.

Make sure of the following:


IMPORTANT: Regardless of your other settings, you must have the following conf.ini command lines for Perfect Water:


[window]
ColourBits=32
StencilBits=8



[Render_OpenGL]

TexQual=3
TexMipFilter=3
TexCompress=0

TexFlags.TexEnvCombine4NV=1
TexFlags.TexEnvCombineDot3=1
TexFlags.DepthClampNV=1
TexFlags.SeparateSpecular=1
TexFlags.TextureShaderNV=1


HardwareShaders=1

water=2 (For ATI graphics cards only, though some very late mode water=4 maybe)
water=4 (For NVIDIA graphics cards only)




Hardware Setup in IL-2 For Perfect Water

Here is the click path for the IL-2 Hardware Setup of Perfect Water:

Main Menu/ Hardware Setup/ Video Options/ Picture Quality/ Custom/ Landscape Detail/ Perfect

REMEMBER to press APPLY.



At this time you should make sure that your conf.ini file has been set to READ-ONLY until the next time that you make changes to it when it would be unchecked as READ-ONLY.

You might want to restart IL-2 to make certain that new settings are applied.

Return to IL2 Mods Trouble Shooting

Who is online

Users browsing this forum: No registered users and 1 guest

cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.