FAQ  •  Register  •  Login

Using UDP Graph and UP 2.01

<<

[OAC]Crow

Posts: 16

Joined: Sun Jan 11, 2009 12:59 am

Post Tue Dec 07, 2010 7:55 pm

Using UDP Graph and UP 2.01

I'm attempting use UDP Graph to measure the performance of certain aircraft in my UP 2.01 installation, only it seems UDP Graph does not want to comply. I was hoping someone here could offer some help.

First, the relevant info:
--I'm running a clean copy of IL-2 v4.09m with UP2.01 installed and the UPUpdater has run and the game is fully up to date.
--My computer sits behind a Linksys router and I only have one ethernet port on my mobo.
--I'm using what I believe to be the latest version of UDP Graph which I downloaded here: http://www.warbirdsofprey.org/index.php?topic=5086.0

What's happening currently:
1. I have my [DeviceLink] parameters set to Port=21100 and host=192.168.1.101. UDP graph has these same parameters (local host parameter is blank).
2. Both my firewall and router have these ports opened and UDPGraph and IL-2 are allowed to send/receive packets via TCP and UDP protocols.
3. I open UDPGraph then IL-2 w/ Ultrapack.
4. After launching a Quick Mission UDPGraph will come up with the variable names (no values) and even determine aircraft that I am flying (which tells me it is at least exchanging some information initially).
5. Beyond that I get no other data. UDPGraph does not display any values of the variables at any time.

What I've tried:
--Changing through every combination of Port, host, IPS and IP, port, locahost combination you can think of. Only the one listed above gives me the aircraft information that lets me know it is connected.
--Starting/stopping the logging feature.
--Changing the variable names and functions.
--Changing the update interval.

Nothing I've done seems to work. Does anyone have any ideas? I can't find any documentation about how make sure UDPGraph will interface properly. The documents provided with the UDPGraph executable are bare bones at best.

Some pics:
Image

Image
<<

[OAC]Crow

Posts: 16

Joined: Sun Jan 11, 2009 12:59 am

Post Tue Dec 07, 2010 8:23 pm

Re: Using UDP Graph and UP 2.01

Disregard. The solution was changing the polling interval to something greater than 199. Apparently 200 is the minimum that the program will function properly.
<<

Storebror

User avatar

Posts: 464

Joined: Fri May 29, 2009 11:43 am

Location: Denmark

Post Tue Dec 14, 2010 4:05 pm

Re: Using UDP Graph and UP 2.01

I've also seen different explanations for the [DeviceLink] section in the conf.ini file, especially regarding the IP address(es).

One version I saw looks like this:
  Code:
[DeviceLink]
port=21100
IPS=10.1.1.3 10.1.1.8


The other one like this:
  Code:
[DeviceLink]
port=21100
host=192.168.0.1


I decided to melt both versions together (to be on the safe side) and now it looks like this for me (when running both UDP Tool and IL-2 on the same PC):
  Code:
[DeviceLink]
port=21100
IPS=127.0.0.1
host=127.0.0.1


Best regards - Mike

Return to IL2 FM Comparing Forum

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.